We recommend that you use the latest version of one of the following browsers, and that you turn on the auto-update setting in your browser.

Update your browser

Please note. If you use Internet Explorer, we recommend that you change to another browser.

New versions of browsers are generally the most secure and reduce the risk of intrusion or other types of security threats.

We do not recommend using older versions of browsers and operating systems, as they do not always support the functionality and security of our websites and the internet bank. Sometimes we stop supporting older, outdated versions.

New versions of browsers are tested by us to ensure they work well with our websites and the internet bank, but not always immediately after the release of new versions.